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Impression can be accessed as a plugin in:

•	 Photoshop CS4+
•	 Photoshop Creative Cloud
•	 Photoshop Elements 6+
•	 Paintshop Pro X
•	 Serif PhotoPlus X5+
•	 Lightroom as an external editor
•	 Aperture as an external editor
•	 iPhoto as an external editor
•	 NOT compatible with photoFXlab or Fusion Express

Accessing Impression in Ps, PsCC, and Pse
To use Impression as a plugin in Ps, Pse and PsCC you 
must first run it as a standalone editor (Mac only). 
Impression will then be available to use in Photoshop 
via the Filter menu. For Windows, the plugin should 
automatically appear in the Filter list.  

Should Impression not appear in the Filter menu, you 
may need to exit out of Photoshop and then re-enter. 

I can’t find Impression in the Photoshop Filter menu

 

Topaz Impression works as both a standalone editor 
and plugin. This means a compatible host editor is not 
required to use Topaz Impression, although you may 
access it as a plugin in a few compatible host editors. 

System Requirements
Mac OS X 10.8 or higher
Windows 7 x64 + OpenGL3.2 
*Does not support Windows 32bit

For additional information on OpenGL and your 
computer’s graphics card, please see page 8.  

Download Instructions
•	 To download Impression please visit topazlabs.

com/downloads. 
•	 Locate Topaz Impression and click on the appropri-

ate Mac or Windows button beneath that product 
to start your download.

•	 The download should start automatically, however 
if prompted, select ‘Save’.

•	 The downloaded installer will then be located in 
your Downloads folder or desktop as an .exe file 
(Windows) or a .dmg file (Mac). 

The program will then install as a standalone editor to:
Mac: Applications folder 
Win: C:\Program Files\Topaz Labs\Topaz Impression

Installation

             Mac dmg 		          Windows exe

http://bit.ly/1tr5oxJ
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Important: Your image will need to be 8-bit or 16-bit and in 
RGB mode. Go to Image-> Mode to change this. 

Accessing Impression in Lightroom
Topaz Impression can be accessed as an external editor in 
Lightroom by going to Photo-> Edit In-> Topaz Impression.

Important: For optimal use of Impression, go to Lightroom-> 
Preferences-> External Editing. 

Make sure that ‘TIFF’ is selected under File Format. In addi-
tion, select 16 bits/component for bit depth and the color 
space ProPhoto RGB for optimal editing. 

Accessing Impression in Corel PaintShop Pro X
To configure Impression as a plugin in PaintShop Pro:
1. Go to File-> Preferences-> File Locations...
2. Scroll to select ‘Plugins from the File types list and click 
‘Add’

Installation
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Select the Topaz Impression folder and click OK.  
4. Click OK again to return back to your main screen.
5. Go to Effects-> Plugins-> Topaz Labs-> Topaz Impression 
and select it to start the program. 

Accessing Impression in iPhoto
To access Impression as an external editor in iPhoto:
1. Run Impression as a standalone editor.
2. Open iPhoto and go to iPhoto-> Preferences.

3. Select ‘Advanced’. 

4. Under ‘Edit Photos’ navigate to the Mac Applications 
folder to select Impression and click Open. It should then ap-
pear in the Edit Photos list. 

Important: Only one external editor can be used at a time. So 
if you are using Fusion Express, photoFXlab, Photoshop or 
another external editing program, you’ll have to forgo using 
them in order to use Impression. 

5. You may also choose to check these settings if you wish:

6. Right click on an image to choose whether to edit it in 
iPhoto or the chosen external editor. 

Accessing Impression in Aperture
To use Impression in Aperture:
1. First you will need to run Impression as a standalone editor.  
2. Your image will need to be 8-bit or 16-bit and in RGB color 
mode.
3. Next go to Aperture-> Preferences. 

Installation
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3. Navigate to: C:\Program Files\Topaz Labs\Topaz Im-
pression 

4. Select the Topaz Impression folder and press OK. 
5. Press OK again to return back to your main screen.
6. Exit out of Serif and then re-open it.
7. To access Impression open an image and go to 
Effects-> Plugin Filters-> Topaz Labs-> Topaz Impression

Installation
4. Under Preferences select Export. 
5. Next to External Photo Editor press Choose...

6. Navigate to your Applications folder and select Topaz 
Impression.
7. Next to External Editor File Format make sure that TIFF is 
selected. 
8. Next to External Editor Color Space choose ProPhoto 
RBG for optimal results. 
9. To Open Impression, go to back to your home screen and 
go to Photos-> Edit with Topaz Impression. 

Accessing Impression in Serif Photo Plus
To use Impression as a plugin in Serif Photo Plus:
1. Go to File-> Preferences
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Entering Your License Key
Upon opening Topaz Impression you should be 
prompted to enter your license key. 

Simply copy and paste your 30 digit license key into the 
provided space to activate the program. Or, if running 
a trial, click ‘Continue Trial’. 

Please know that there is no difference between the 
trial and purchased versions of Impression. The only dif-
ference is the license key used to activate the program. 

Should you receive an activation failure, please make 
sure that you have copied (ctrl/cmd + C) and pasted 
(ctrl/cmd + V) the key. Also be sure that you did not 
copy any extra blank spaces.

For additional license key assistance, please see our 
knowledge base: 
•	 My license key is not being accepted

By Darren Neupert

Installation

By Randy Mick

https://support.topazlabs.com/hc/en-us/articles/200141036-My-license-key-is-not-being-accepted-
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Installation
Graphics Cards and Open GL (Windows only)
Upon installing Impression, you’ll receive a message similar to 
below, indicating whether or not your graphics card can sup-
port the program (requires OpenGL 3.2 or higher). 

Should your graphics card not meet the requirements, you’ll 
need to update your video card by going to the link given at 
the bottom of the Open GL Test message. 

To detect which graphics card you are running:
1. Right click on the desktop and select ‘Screen resolution’
2. Next, select ‘Advanced Settings’
3. You’ll then see information regarding your graphics card. 

Please refer to these knowledge base articles for additional 
assistance if needed:

Which video cards are supported with Impression?
Topaz Impression and OpenGL

Common Issues:
1. You receive this message upon open Impression, causing it 
to crash:  “tlimpression.exe has stopped working”

You will need to update your Intel graphics card in order 
to resolve the issue. You must first uninstall your outdated 
graphics card and reboot your system before updating it. 
Please see this article for additional assistance on this:

Impression Crashing on Startup in Windows - Intel Graphics

2. You open Impression and see a red screen:

You will need to update your AMD graphics card to resolve 
this issue. Please see this article for additional assistance, 
which includes links to a direct download:

Red Screen issue when using ImpressionPlease visit our knowledge base at topazlabs.com/support 
for additional assistance if needed. 

http://Which video cards are supported with Impression?
https://support.topazlabs.com/hc/en-us/articles/203307826-Topaz-Impression-and-OpenGL
http://bit.ly/ZCjBdp
http://bit.ly/11jn3uL
http://bit.ly/1rbEt6S
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To uninstall Topaz Impression please follow these 
instructions:

Mac
1. Quit Photoshop (or other editing program).
2. Navigate to the Applications folder: Macintosh HD 
-> Library -> Applications-> Topaz Impression. 
3. Locate the Topaz Impression folder and move it to 
the trash. You will need to enter your system pass-
word to OK this change. 

 Windows 
1. Quit Photoshop (or other editing program).
2. Click on the Start Menu and select Control Panel 
-> Programs -> Programs and Features (or Uninstall a 
Program). 
3. Select Topaz Impression and click uninstall.  

Uninstalling

Before After

By
 R

ob
yn

 A
be

r

By Flick Coleman

By Denise Silva
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Be the Artist

Designed to help you transform your image into a realistic 
looking work of fine art, Topaz Impression contains a di-
verse range of tools, including several brushes and dozens 
of textures that’ll allow you to add a unique touch to your 
photo. 

Working with the selective parameters, you can control 
the size, thickness, hue and so on of the decided medium 
to create your masterpiece. No prior knowledge of art is 
required, only the want and ability to have fun!

Why ‘Impression?’ you might ask. The name of this pro-
gram was inspired by the style of painting called Impres-
sionism that emerged in France in the mid-19th century. 
Impressionism was a reaction to Realism, a style of paint-
ing that aimed to depict the subject exactly as shown. Re-
alism was sometimes considered a flamboyant showcase 
of the artist’s skill, showing off that he could depict reality 
in the most accurate manner. 

Tired of focusing on reality and the ego, painters like 
Monet, Renoir and Degas branched out of the norm and 
paid less attention to a scene’s details by painting with 
sketchy brushwork and thick strokes (impasto). Paint 
would rapidly be laid onto wet paint, as the Impressionists 
were inspired by the lighting and color around them.

While a photo conveys a record in time, Topaz Impression 
alters this reality, allowing you to creatively change this 
realistic recording of light into a new impression. From oil 
paintings to charcoal drawings to chalk street art, it’s your 
turn to be the artist! 

Introduction

Visit the Impression Gallery to view more examples!

By Shaun Locock

By Sam Saliba

http://bit.ly/ImpressionGallery
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Main Features
Here are some unique features in Topaz Impression:

1. Presets and Collections inspired by art history and 
different artistic styles. From ancient to modern art, 
you might just find that the Da Vinci Sketch, Chiaroscu-
ro or Cezanne preset is your favorite. 
 
2. Simulated brush strokes. Actual media strokes using 
oil paint, colored pencil, watercolor and so on were 
scanned and masked out with Topaz ReMask to put 
into the program’s algorithm. 

3. HSL Technology in 8-Colors.  Easily adjust the hue, 
saturation and lightness of the overall image or by indi-
vidually selecting one of 8 different colors. 

4. Lighting Effects.  Add to your artwork by adjusting 
the contrast, brightness, vignette and light direction.

5. Textures.  Choose from dozens of surface textures 
including brick, canvas, wood, rock and several differ-
ent types of paper. 

6. User Interface Design.  With Impression, we have 
continued to develop a cleaner, more modern and 
efficient interface to improve usability, workflow and 
overall aesthetics. 

Introduction

Oil brush strokes drying
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Here’s what’s new in version 1.1 of Impression:

1. Split view modes. Located in the top left corner, this allows you to 
compare the original image next to the edited image in 5 different 
viewing modes. 

2. New Shortcut Keys. These shortcut keys have been added:
•	 Zoom in or out: Ctrl/Cmd +,-
•	 Switch the preset panel to the selective parameter panel: Shift + P 

(or simply press P)
•	 Cancel: Esc
•	 Ok: Ctrl/Cmd + Return (Enter)

Introduction

Split HorizontalSplit Vertical
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Access the Preferences in the top left 
corner of the interface. 

To access the Vignette Center, you  must first increase the Vignette slider (same with Coverage 
Center and the Coverage slider).

What’s new in version 1.1

3. Added Preferences. The preferences menu now contains these op-
tions:
•	 Start with example image
•	 Start With Preset Panel
•	 Update Slider value while dragging
•	 High Resolution processing

4. New brushes and presets. 5  0+ new presets and 3 brushes have 
been added into the 1.1. udpate.  In addition, there is one new collec-
tion, the Pictorial Collection. 

5. New selective parameters. A Coverage Center and Vignette Cen-
ter have been added. You can now choose where the coverage and 
vignette are centered on an x & y axis.

6. New zoom options. A new zoom capability has been added in the 
top left menu of the interface. Impression preferencesWhen zooming 
in or out, in the top right corner of the interface a navigation screen 
has been added. Use the mouse to scroll in and out. When zoomed all 
the way, the ‘+’ navigation option will appear. To make it disappear, 
zoom all the way out.

Introduction
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Work Area

User Interface
There are two main areas to Impression: presets and selective parameters. 
Upon entering the program you will see a list of presets by default. This is a 
good starting point for applying effects to your image. 

Browse through several 
different collections from 
the top pull down menu. 

Use the shortcut key Shift + P to switch back and forth between the selective parameters and presets. You can also decide if you want the presets or 
selective parameters to open each time you enter the program. In the top left corner go to Topaz Impression-> Preferences to make these changes. 
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Presets & Collections
There are six Collections in Topaz Impression that 
contain a range of effects: Ancient, Modern, Impres-
sionistic, Painting, Pencil and Charcoal & Pastel

The Ancient Collection

The Modern Collection

Cave Dweller painting

Da Vinci inspired drawing

Urban Street Art

Abstract colors, inspired by the Post-Impressionist, Paul Gauguin

By
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The Impressionistic Collection

Impasto

Chiaroscuro

By
  R

ob
yn

 A
be

r

By
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Oil Painting

The Painting Collection

By
 D
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ita

l  L
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y 
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d

Monet preset

Photo Painting

Pointillism

By
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The Pictoral Collection

Obscurity
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Graphite Sketch Graphite + Colored Pencil

By
 M

ik
e 
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ge
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By
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Selective Parameters
Should you want to customize the preset or make your 
own, you must navigate to the selective parameters 
screen. These sliders are the backbone of the program 
(and how the presets were created). 

To access the selective parameters, click on the actual 
preset. You’ll then see the selective parameters 
icon appear. Click on it to navigate to the selective 
parameters screen. 

Another way is to click on the               icon in the top 
right corner or press Shift + P.

To return back to the presets, click on the           icon or 
press P. 

To reset all parameters, click on the reset icon in the 
top right corner. 

To create a new preset within the parameters, click on 
the + icon.

The Pencil Collection

Im
ag

e 
© 
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hn

 C
am

pi
on

Work Area

The Charcoal & Pastel Collection

Deletes 
preset

Chalk Pastel
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Selective Parameters
The parameters (or sliders) are divided into four sec-
tions: Stroke, Color, Lighting and Texture. Each selec-
tive parameter, or slider, performs a unique task. After 
studying what each does and experimenting, you’ll be 
an expert in no time! 

S T R O K E
Brush

Start by choosing a medium. You can choose from 
paintbrushes, pencils, chalk, etc. These strokes were 
simulated from actual paint strokes, scanned and then 
masked out using Topaz ReMask before being placed 
into the program’s algorithm.

Brush Size
This determines the size of the brush stroke. 

Brush Size: 0 Brush Size: 1

Paint Volume
Determines the thickness of the selected medium. 
Increase the slider for an impasto look, a painting tech-
nique that involves a thick application of paint.  

Paint Opacity
Determines the transparency, or how see-through the 
paint or selected medium is. 

Paint Volume: 1 Impasto-like painting

Paint Opacity: 0 Paint Opacity: 1
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Determines how wide the selected medium’s strokes 
are. 

Stroke Length
Determines how long the selected medium’s strokes 
are. 

Spill
Determines how clear the edge of the stroke is applied. 

Smudge
Blurs and smooths the edges of the stroke. Use to create a 
dreamy or photorealistic look. 

Coverage
Determines how far the medium is spread across the surface. 
When decreased the edges of the background will start to 
show. 

Coverage Transition
Determines the harshess of the coverage. 

Coverage Center
Choose where the coverage is centered on an x & y axis.

Stroke Width: -1 Stroke Width: 1

Stroke Length: -1 Stroke Length: 1

Spill increase to 1. By increasing this setting, you’ll literally 
see the medium “spill” over the edges of outline. 

Smudge: 1
Paint Opacity: 0.74
Stroke Length: -0.65

Coverage: 0.21
Transition: 0

Coverage: 0.21
Transition: 0.27

Coverage: 0.21
Transition: 1

Work Area
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The color section is an HSL (hue-saturation-lighting) 
panel where you may adjust the overall or individual 
colors of 8 different hues: red, orange, yellow, green, 
aqua, blue, purple and magenta. 

Hue
Allows you to alter the color of the selected or overall 
hue. For instance, you can change a yellow flower to a 
red one. 

Saturation
Changes the color’s vividness and intesity. 

Original image Hue shift in yellow

Green & Yellow saturation: 0 Blue & Aqua saturation: 0

Lightness
Changes the brightness or darkness of the color. 

Blue lightness: -0.40 Blue lightness: 0.30

Tip: Hover over an individual color to see where it appears 
in your image. Diagonal red lines will appear to indicate the 
specific color selected. In the below example, the red lines 
indicate blue. 

Work Area
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Brightness
Determines how bright or dark the image is. Note that 
this does not affect the background.  

Contrast
Determines the separation between the lightness and 
darkest tones (or values) in the image. 

Vignette
Controls the darkening of the image’s corners. Use a 
vignette to draw the eyes towards the center of the 
image, adding emphasis to it. 

Vignette Transition
Determines how harsh the vignette’s transition is. 

Vignette Center
Choose where the vignette is centered on an x & y axis.

Vignette 0.52
Transition: 0.50

Vignette: 0.52
Transition: 0

Light Direction
Works specifically with paint volume and texture to al-
ter the way light hits the canvas. Light can be adjusted 
horizontally (x-axis) or vertically (y-axis). 

Note: You must increase the Texture Strength slider for 
this option to appear. 

T E X T U R E

Choose from a variety of textures for a unique look.

x: 1.00, y: 1.00 x: -0.73, y: -0.29



22

User Manual
To

pa
z 

Im
pr

es
si

on
Work Area

Strength
Determines how much of the texture comes through. 

Size
Determines the scale of the texture from small to large. 

Background
Allows you to choose a different background color 
other than the default white.  

Rock texture Wood texture

Other Menu Options
There are a few other options in the Impression inter-
face that you have the option of using. Let’s start with 
the top left corner. 

•	 To view the original image, click on the Original but-
ton:                              (or press the spacebar)

•	 Zooming: To zoom in on the image, click on the 
magnifying glass icon.                (Shortcut key: Ctrl/
Cmd +,-)

Now let’s move to the bottom left corner of the inter-
face.

•	 Strength: adjust the strength slider to reduce the 
opacity, or transparency, of the effect. 

•	 Blend Mode:  Decide if you want the effect to 
interact with the original image. 
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This is the standard blending mode, which only affects 
the top image without blending in the original. 

Multiply
Darkens the image. A dark blend color will produce 
darker base colors. Lighter blend colors will only be 
tinted

Screen
Lightens the image. Will produce lighter, bleached base 
colors. Darker blend colors will lighten the base colors 
less. 

Soft Light
Applies a light tint and softens the base color. Pre-
serves the luminosity of base colors. 

Hard Light
Lightens (screens) the base colors for lighter blend 
colors. Darkens (multiplies) darker base colors. Also 
increases the contrast of the blend color. 

Overlay
Multiplies (darkens) dark base colors and screens 
(lightens) light base colors while preserving luminosity.       

Work Area
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Saving Your Image
Saving your image within Impression is a fairly simple 
task. To save navigate to the bottom right corner and 
select ‘Save As’

Another way to save your image is to navigate to the 
top menu bar and select File-> Save As

You’ll then have the option to name the file and choose 
the file types: JPEG, TIFF and PNG

Depending on the file type, you’ll then be presented 
with several options including color space and bit 
depth. 

By Joe Reardon

By Lewis Mann
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Tutorials

Create an Impressionistic Painting

In this tutorial learn how to turn your image into a 
masterpiece using the selective parameters in Topaz 
Impression. 

Impressionism is a style of painting that was formed in 
1874 in Paris by a group of painters who were rejected 
from the art establishment and decided to start their 
own exhibition. Impressionism is defined by an un-
finished, sketch-like appearance with rapidly applied 
brush strokes. 

Another characteristic is the subject matter...land-
scapes and scenes from daily life are common subjects 
found in impressionistic paintings. Rather than sitting 
in a studio, painters like Monet, Renoir and Degas 
painted en plein air. They had to paint quickly outdoors, 
hence the need to capture quick impressions of any 
given scene.

1. To start, open up a nature or landscape photo of your 
choice. 

2. Navigate to the selective parameters screen and press 
reset to rid of any previous effects

3. Select brush type 1.

4. Navigate to the Lighting panel. Impressionists typically 
did not use black paint, so decrease the 
Contrast slider a tiny amount.  

5.  Next go to the Color panel and increase the Satura-
tion slider by 0.05 for more vibrant colors. 

6. Impressionist paintings usually have an opaque sur-
face, so increase the Paint Opacity slider to make the 
brush strokes more apparent.

7. Impasto is a technique where paint is laid on thickly to 
the canvas...this style was commonly found in impres-
sionistic paintings. Increase the Paint Volume slider to 
convey this style.

8. Impressionist painters painted with a variety of brush 
strokes from long applications to short dabs. Adjust the 
Stroke Width and Stroke Length sliders to create a brush 
stroke that fits with your mood and the subject you have 
chosen.

9. Increase the Brightness under Lighting by 0.05. Since 
Impressionists painted outdoors, much white pigment 
was used in their paintings to catch the light. 

10. You may also choose to work with individual colors 
in the image, such as the greens and blues, adjusting the 
saturation, hue and lightness. Simply select the color

Before After
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you wish to work with and adjust the Hue, 
Saturation & Lightness sliders as desired. 

11. We will not be making any texture
adjustments. Since the paint has been laid 
on thickly, there will not be any texture
coming through on our painting. 

12. Once finished making adjustments,
save your preset for future application if
you desire. Name the preset something
memorable, like “Sun-drenched Meadow”
or “Misty Day”. 

Using Layer Masks 

Topaz Impression does not have a masking capability at 
the moment, however should you own a program like 
Photoshop or PaintShop Pro, it is possible to use layer 
masking for ultimate artistic control with Impression. 

In this tutorial you will learn how to use layer masks 
with Photoshop. This is a great technique to learn 
should you want an effect selectively applied to certain 
areas of your image but not others. For instance, you 
can create mixed media looks using layer masking. 

1. To start you will first need to configure Impression as 
a plugin in your host editor (see the installation instruc-
tions on page 3). 

2. Open an image and then duplicate the background 
layer by either going to Layer-> Duplicate Layer (short-
cut  Ctrl/Cmd + J).

3. Open Topaz Impression from the Filter menu. 

4. Apply any effect that you desire. For this example 
I apply the Impasto II preset from the Impressionistic 
Collection. I like this look, however I do not like the 
random brush strokes of brown in the sky:

5. Press OK to return back to Photoshop to fix this.  

6. With your background copy layer selected, go to 
Layer-> Layer Mask. You will see two options here: 
Reveal All and Hide All. These two options let you paint 
in or paint out the filter’s effect with Photoshop’s brush 
tool.
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7. Click Reveal All to get a white mask in your layers 
panel. White areas in a mask permit pixels to be seen.

8. To invert the selection, turning the black mask to 
white and vice versa, press Cmd/Ctrl + I. By clicking 
Hide All, you’ll get a black mask. Black areas hide pixels.

9. Start with a white mask to brush in the effect. Before 
brushing in, you’ll need to make sure that your fore-
ground color swatch is white.

10. The color swatches will be located at the bottom 
of your toolbar. The default colors should be black and 
white…press Ctrl/Cmd + D to reset them.

11. The color in front represents the foreground color, 
while the color behind it represents the background 
color. Remember, white = keep and black = hide. 

12. To toggle back in forth between the two, press the 
X key. This is useful should you make a mistake and 
need to ‘erase’. 

13. Next, select the brush tool in your toolbar (shortcut 
key: B). Should another tool be selected, right click (or 
Ctrl + click) to expand the options to access the brush 
tool.

14. Now we are ready to begin painting back in the ef-
fect. But first, you may want to adjust the size of your 
brush ( [ , ] keys). In the top menu bar there will also be 
a variety of brush options too, like opacity and flow.

Tip: If you start to brush in the effect but nothing hap-
pens, make sure that the layer mask is selected. Simply 
click on the black (or white) mask to select it.

15. With a small brush size and reduced brush opacity, 
start painting out the effect where you wish to remove 
it. 
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Tutorials

As you can now see, the impasto effect has been removed from the sky. From this point, you can duplicate the background layer again and 
bring it into Topaz Impression and apply a different effect to the sky. You can even blend the two together back in Photoshop by reducing 
each layer’s opacity. Layer masking is an ideal choice for those who want more creative possibilities. Should you want to create mixed me-
dia effects and such, this is the way to go. 

Before
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Here’s another creative example of how layer masking was 
used to create a mixed media look with paint & colored pencil:

Before

After - Impasto blended with colored pencil

Tutorials

By Digital Lady Syd
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Here are more examples submitted by beta testers. 

By Peggy Hughes

By Joe Reardon

By John Campion

By Gary Lamott

By Jim Crabtree

By Tony Sweet
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Pc?
Yes, you may use the purchased software on two 
operating systems at a time. Your license key will 
work in both versions. The correct software can be 
downloaded from our downloads page at topazlabs.
com/downloads. 

“I can’t find Impression in the Photoshop Filter menu”
To access Impression in the Filter menu, you will first 
need to run Impression as a standalone editor (Mac 
only). After that, restart Photoshop and Impression 
should then appear in your Filter menu. Should that fail 
to work, please do the following to resolve the issue: 

Mac:
1. Go to Applications folder and right click on the 
Impression icon. 
2. Click on ‘Show Package Contents’-> Contents-> 
Resources
3. Then copy the Topaz_Impression.plugin to your PSCC 
2014 (or Photoshop, PSE) plugins folder.
4. Restart PSCC 2014 (or Photoshop, PSE) and 
Impression should show up in the Filter menu. 

Windows: 
1. Go to C:\Program Files\Topaz Labs\Topaz Impression 
and right click on the Impression icon. 
2. Click on ‘Show Package Contents’-> Contents-> 
Resources
3. Then copy the Topaz_Impression.plugin to your PSCC 
2014 (or Photoshop, PSE) plugins folder.
4. Restart PSCC 2014 (or Photoshop, PSE) and 
Impression should show up in the Filter menu.

“I need a Topaz Impression trial key.” 
Please visit topazlabs.com/downloads to request a trial 
key for the software.  

“Do you have any Impression tutorials?”
Stayed tuned for more Impression tutorials on our blog 
at blog.topazlabs.com. You can also check us out on 
YouTube at youtube.com/topazlabs. 

“I don’t  have Photoshop, will Impression work with 
my Elements, Aperture, Lightroom, iPhoto, Paint Shop 
Pro, or PhotoImpact?”
Yes, Impression is a standalone editor and doesn’t 
require a host editor to be used. See page 3 for where 
the software installs to and how to access it as a plugin. 

“Why is Impression grayed out in the Filter menu?”
Please make sure that your image is 8bit or 16bit and in 
RGB mode. To detect your image’s settings, go to Im-
age-> Mode.

Please also be sure that your layer is selected in the lay-
ers panel and that an adjustment layer is not selected. 

“If I use the 30-day trial version will I need to uninstall 
the trial version before I upgrade to a full version?”
No, there is no difference between the purchased 
software and trial software. The only difference is the 
license key used to activate the program. 

FAQ’s

http://topazlabs.com/downloads
http://topazlabs.com/downloads
http://topazlabs.com/downloads
http://blog.topazlabs.com/
https://www.youtube.com/user/topazlabs
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Impression?”

Should your screen be black upon opening Topaz 

Impression, please do the following:

Mac:

1. Go to ~/Library/Application Support (you can access 

‘Go’ in your top menu bar on your desktop). 

2. Right click on folder ‘Topaz Labs’ and select ‘‘ select 

‘Get Info’

3. Change the permission of current user to ‘Read & 

Write’ and then press OK

4. Restart Topaz Impression

w

Windows:

1. In your address bar type %appdata% and it will bring 

you to the appdata/roaming folder

2. Go to the upper folder and then goto the 

AppData\Local\Topaz Labs\Topaz Impression\QML\

OfflineStorage\Databases folder

3. Delete everything inside that folder

4. Restart Topaz Impression

“Does Impression work with PhotoFXlab?”
Unfortunately Topaz Impression does not work with 
photoFXlab at the moment. We will need to update 
photoFXlab in order to support Impression. It is still 
undecided whether this is to be implemented.

“Why doesn’t my complete collection key work with 
Impression?”
Impression requires its own license key to be activated, 
so complete collection license keys will not activate 
Impression.  

“Does my complete collection come with 
Impression?”
If you purchased a complete collection before the 
release of Impression, then you’ll have to purchase a 
copy of Impression. While individual product upgrades 
with Topaz are complimentary, complete collection 
upgrades are not free. 

I have a question not listed here. 
Please visit our knowledge base online at topazlabs.

com/support.

By Freddie Ross

http://topazlabs.com/support
http://topazlabs.com/support
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Connect with Topaz

Follow us on Twitter (@topazlabs) 
for notifications of recent news and 
easily get in touch with us whenever 
you feel like it!

Find us on our Facebook page and 
network with other Topaz users!

Participate in the entirely user-led 
Topaz Flickr group for a helpful and 
highly active community for Topaz 
Photoshop plug-ins!

Subscribe to our YouTube channel 
to keep up with any newly released 
product video tutorials!

Check out our blog for tutorials, tips 
and updates from Topaz Labs!

And don’t forget to check out our 
other social media outlets including: 
Instagram (@topazlabs), Pinterest, 
LinkedIn and Google+!

https://twitter.com/topazlabs
https://www.facebook.com/topazlabs?ref=tn_tnmn
https://www.flickr.com/groups/topaz/
https://www.youtube.com/user/topazlabs
http://blog.topazlabs.com/
http://instagram.com/topazlabs
http://www.pinterest.com/topazlabs/
https://www.linkedin.com/company/1089626?trk=tyah&trkInfo=tarId%3A1411055519738%2Ctas%3Atopaz%20labs%2Cidx%3A1-1-1
https://plus.google.com/+topazlabs
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Topaz Labs LLC, a privately owned company headquartered in Dallas, Texas, focuses on developing advanced image en-
hancement technology. With today’s widespread use of digital still cameras, the need for high-quality digital images has 
greatly increased.  Topaz Labs’ mission is to bring practical state-of-the-art image enhancement technology to both profes-
sionals and consumers.

Contact Information
	
Headquarters
Topaz Labs, LLC 
4100 Spring Valley Road
Suite 103
Dallas, TX 75244

Topaz Labs, LLC
904 West Ave
Suite 102
Austin, TX 78701

Technical Support
Visit: topazlabs.com/support
Email: help@topazlabs.com 

Copyright © 2014 Topaz Labs, LLC. All rights reserved. www.topazlabs.com
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Photo Enhancement Plug-ins	 			 

Go to topazlabs.com/downloads to get your 30-day free trial!

Ultimate control over 
image exposure, 
detail, and color gives 
you the power to 
make your photos 
pop.

Develop unique and 
compelling pho-
tography with the 
most technologically 
advanced software 
available.

Create powerful 
photos & flawless 
image definition. 
Intelligently and 
dynamically enhance 
image contrast.

Specializes in creating 
crisp and stylized 
images. Also features 
extensive smoothing 
capabilities.

Advanced JPEG 
artifact reduction 
filters eliminate JPEG 
compression artifacts 
while preserving im-
age detail like never 
before. 

Advanced high-ISO 
noise reduction tech-
nology that eliminates 
noise while effort-
lessly maximizing and 
retaining image detail.

Output & creative 
sharpening with three 
levels of intricate 
and specific detail 
enhancement.

The superior capture-
sharpening solution 
that actually recovers 
lost detail and refines 
with micro-contrast 
detail enhancement.

Your virtual camera 
bag of effects simu-
lated from real lenses 
and filters. Effects in-
clude creamy bokeh, 
old school filters and 
more!

Remove unwanted 
backgrounds from 
your digital images 
quickly and easily with 
ReMask. 

Expand your creativity  
alter your image’s 
look by applying one 
of over a thousand 
color filters.

Transform your 
regular photo into a 
beautiful work of art,  
such as an oil painting, 
watercolor, line & ink 
drawing and more!

Create beautifully 
rendered and natural 
lighting effects in 
seconds!

Our standalone editor 
that is a one stop 
workshop for access-
ing all of your Topaz 
plugins. Can also work 
as an external editor 
(replacing Fusion). 

Our free external edi-
tor required to use To-
paz Labs in Lightroom, 
iPhoto and Aperture. 
PhotoFXlab can be 
used in its place as the 
external editor.

http://topazlabs.com/downloads 

